PDA

View Full Version : AEG gives out a whine



benc64
03-18-2004, 12:46 PM
My Sig 552 used to fire very quietly and smoothly, but last week a sharp whine started to accompany each shot, could this be because of a ripped bucking, or just the sign of an aging gun?
Thanks

Obsidian
03-18-2004, 01:23 PM
does it still fire? Could be a couple of things. Sounds kinda like the motor is not in the right spot.

benc64
03-18-2004, 03:14 PM
Yes it still fires, just not as quietly as it used to.
So, you think the engine has moved around?

AustinWolv
03-22-2004, 03:30 AM
Very likely that the motor set screw on the end of the pistol grip has backed out. The motor pinion gear is not meshing properly with the bevel gear; hence, you hear the high-pitched whine now.

benc64
03-22-2004, 11:16 PM
So I just need to screw that one screw in and that will fix the problem?

Katana
03-22-2004, 11:42 PM
I wouldn't screw it all the way in right away. If it really is a pinion gear mesh problem (and I agree with the others here that your description of the sound makes that likely), then slowly adjust that set screw while firing and listening to the sound. If it has an affect, find the location where it sounds best, and lock-tite the set screw, or put some nail polish across it to lock it down.

If that doesn't have any affect on the whining, you'll have to crack the mechbox and start looking at the teeth on the other gears, etc. Lubrication and shimming will also be things to examine.

Mouse
03-22-2004, 11:53 PM
When you pop it open, be sure you know what you are doing or have somebody close at hand that does. Popping open a mechbox without proper knowledge can lead to bad things.